This is the #1 question we get and of course there are many possible reasons, but here’s the top 3 reasons we’ve seen.

 

1) Incorrect Sales Channel setting on the template.

On each template you can set which purchasing Sales Channel (i.e. Amazon website that the customer bought from) this template gets applied to. If you don’t select a Sales Channel it will never get sent, even if it is active. ¬†Unless you have a specific reason not to, we suggest setting the Sales Channel to ‘All’. The only reasons not to are if you have other templates that send out to other channels. The way Amazon works, it is quite possible your Amazon.com product will get sold on Amazon.ca (Canada) or Amazon Mexico and in this case your email wouldn’t go out. (Same is definitely true of Amazon.co.uk as Amazon shares across Europe).

2) Incorrect ‘Send to Orders Placed After’

We added this feature to help you migrate from another auto-responder platform. If you are not migrating completely disregard this field. If you are migrating you can choose a cut off date. Note that the date is for orders PLACED after. So even if your template triggers on shipping, this applies to the order purchase date.

3) Items Not Added

The Way ZonMaster works is that it checks an order to see if it contains any of the items in your template. If you don’t add an item to your template, emails will never get sent to purchasers of that item. At the moment we don’t have a ‘Apply To All’ setting…you need to add all your items. Also, if you add new items to Amazon, you need to come back to us and add those items into your email template.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.